@ompugao_ blog

hello this wonderful world

build libuv on ubuntu (kernel 3.x)

mruby-uvを使いたい
libuvをubuntu preciseにインストールしようとするもエラー
→ READMEにはkernel 2.6系をsupportすると書いてある
→ 試しにdebian squeeze(kernel 2.6.x)でbuildしたら動く
→ ふむkernel 2.6系でないとダメか
→ kernel コンパイル
→ nvidiaまわりで不具合
→ \( ‘ω’)/ウォァァァァ
→ libuvってそんなにkernelに食い込んでるのか?
→ エラーログをぼーっと眺めつつ、なんとなくconfig-unix.mkの

ifeq (linux,$(OS))

ifeq (Linux,$(OS))

にしてみる
→動くじゃんorz

Comments